Piwik gives “Error: PHP version > 5.3.3 required” during install

When trying to install Piwik 2.8.3 I kept getting “PHP version 5.3.3 PHP version > 5.3.3 : Error: PHP version > 5.3.3 required” even though my server was running PHP 5.3.3.

To fix this I modified piwik/core/testMinimumPhpVersion.php

Change line 19 from
$piwik_minimumPHPVersion = '5.3.3';
to
$piwik_minimumPHPVersion = '5.3.2';

Upload this file to your webserver and overwrite the existing file then refresh the system check page, it should get past that stage now.

Leave a Reply

Your email address will not be published. Required fields are marked *