How to re-install Management Point on a Secondary Site

Problem: The Management Point on a secondary site is not working. In the SCCM logs you can see the following error: MP Could not write CCM setting to WMI. The operating system reported error 2147950650: The server is not operational.
error1

Solution: Re-install the Management Point. Since this site system is a Secondary Site I could not simply remove the role and re-add it (A management point is a requirement for a Secondary Site). Rather than do a full repair of the secondary site I want to trigger a re-install of the MP role. The easiest way to do this is within the SCCM Configuration Manager Console.

Under Administration -> Site Configuration -> Servers and Site System Roles click the server which is having the issue then under Site System Roles right click Management Point and select Properties.

Under the management point properties change the client connection to HTTPS, this will trigger the MP to re-install on the site server.
management-point

Now you most likely will not have SSL configured on IIS so this will fail, which is expected. After 5 minutes change the settings back to HTTP client Connections which will trigger the MP to re-install again and this should resolve the issue.

Keep an eye the MPSetup.log on the Management Point Server, it should look something like this towards the end:
<02/02/15 09:57:42> New SMSMP is the same product code. This is a minor upgrade.
<02/02/15 09:57:42> Enabling MSI logging. mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
<02/02/15 09:57:42> Installing C:\Program Files\Microsoft Configuration Manager\bin\x64\mp.msi REINSTALL=ALL REINSTALLMODE=vmaus CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
<02/02/15 09:58:51> mp.msi exited with return code: 0
<02/02/15 09:58:51> Installation was successful.
<02/02/15 09:58:51> ~RoleSetup().

wp_review_location:
bottom
wp_review_desc_title:
Summary
wp_review_color:
#1e73be
wp_review_fontcolor:
#555555
wp_review_bgcolor1:
#e7e7e7
wp_review_bgcolor2:
#ffffff
wp_review_bordercolor:
#e7e7e7

Leave a Reply

Your email address will not be published. Required fields are marked *